Ubuntu下安装python graph-tool安装 第三方库



1、添加软件源 

注意:ubuntu版本对应

14.04         trusty  
14.10         utopic  
15.04         vivid 
15.10         wily 
16.04 LTS     xenial

如: 版本为ubuntu15.04 时,以下/etc/apt/sources.list中添加的文本中wily就需要改为vivid

如果我们的Linux系统是Ubuntu15.10系统

修改/etc/apt/sources.list

deb http://downloads.skewed.de/apt/wily wily universe
deb-src http://downloads.skewed.de/apt/wily wily universe


2、添加软件源后,进行软件库的更新操作

更新apt-get软件源

sudo apt-get update

这时会出现缺少pulic-key的提示。

Release: The following signatures couldn't be verified because the public key is not available: 
 NO_PUBKEY 2EA8F35793D8809A

然后复制出提示公钥,执行

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2EA8F35793D8809A

再次执行软件库的更新操作,就ok了

sudo apt-get update

然后使用apt-get命令安装,命令如下: 

python2执行:

sudo apt-get install python-graph-tool

python3执行:

sudo apt-get install python3-graph-tool

在python的交互模式中引入包中所有模块验证是否安装成功:

from graph_tool.all import *


不报错说明graph-tool这个包已经安装在你的环境里了,所以引用他们就不会报错。

一但报错,说明安装不正确,或者未安装上。


温馨提示:欢迎注册本网站!共同创建可用IT资源。




最后于 8月前 被admin编辑 ,原因:

网际编程技术论坛-微蓝网-aiweline.com- 版权声明 1、本主题所有言论和图片纯属会员个人意见,与网际编程技术论坛-微蓝网-aiweline.com立场无关。
2、本站所有主题由该帖子作者发表,该帖子作者Python网际编程技术论坛-微蓝网-aiweline.com享有帖子相关版权。
3、网际编程技术论坛-微蓝网-aiweline.com管理员和版主有权不事先通知发贴者而删除本文。
4、其他单位或个人使用、转载或引用本文时必须同时征得该帖子作者Python网际编程技术论坛-微蓝网-aiweline.com的同意。
5、帖子作者须承担一切因本文发表而直接或间接导致的民事或刑事法律责任。
6、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责。
7、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意。


上一篇:scrapy爬虫出现Forbidden by robots.txt 被robots拒绝
下一篇:Debian下安装python graph-tool安装
快速回复
这家伙太懒了,什么也没留下。
最新回复 (0)
只看楼主
全部楼主
    • 网际编程技术论坛-微蓝网-aiweline.com
      2
          
返回
免责声明:本站部分内容来源于网络,若有侵权请及时通知(aiweline@qq.com),我们会及时处理。